Ignore:
Timestamp:
Feb 11, 2011, 1:19:04 PM (9 years ago)
Author:
sam
Message:

Try to autodetect GtkGL development libs, and don't build the Deus Hax
editor if not found.

File:
1 edited

Legend:

Unmodified
Added
Removed
  • trunk/configure.ac

    r623 r628  
    9999
    100100dnl Use GTK+? (required for the deushax editor)
    101 GTK_CFLAGS="$GTK_CFLAGS `pkg-config --cflags gtk+-2.0 gtkgl-2.0`"
    102 GTK_LIBS="$GTK_LIBS `pkg-config --libs gtk+-2.0 gtkgl-2.0`"
     101ac_cv_my_have_gtkgl="no"
     102PKG_CHECK_MODULES(GTK, gtk+-2.0, [ac_cv_my_have_gtkgl="yes"], [:])
     103PKG_CHECK_MODULES(GTKGL, gtkgl-2.0, [:], [ac_cv_my_have_gtkgl="no"])
     104if test "${ac_cv_my_have_gtkgl}" != "no"; then
     105  AC_DEFINE(USE_GTKGL, 1, Define to 1 to use GtkGl)
     106fi
     107AM_CONDITIONAL(USE_GTKGL, test "${ac_cv_my_have_gtkgl}" != "no")
     108#GTK_CFLAGS="$GTK_CFLAGS `pkg-config --cflags gtk+-2.0 gtkgl-2.0`"
     109#GTK_LIBS="$GTK_LIBS `pkg-config --libs gtk+-2.0 gtkgl-2.0`"
    103110
    104111# How to use the Lol Engine inside this tree
Note: See TracChangeset for help on using the changeset viewer.